Jump to content


Unbrick wr703n wifi router

Posted by fertito , 14 June 2012 · 57584 views

if like myself you push the thing a little too far, you should find this usefull ;)

If nothing is responding anymore on your router :

locate the GND, TX and RX on the board :
Posted Image

solder some wire on it, this is very difficult, because it is really small and the solder doesn't stick well on it. Once it is done, glue everything and let some easy access wire, that could be usefull after.

Plug a 3.3V ttl serial adapter (pl2303, ftdi, ...) on the wire and open a serial terminal (minicom, realterm, docklight, ...) @ 115200/8/N/1/XON-XOFF.

power on the wr703n and quiclky send "tpl" followed by enter to the terminal, this will make the wr703n enter in rescue U-boot hornet.

install a small tftp server on your computer (ex: http://tftpd32.jounin.net/) and plug an ethernet cable between your computer and the wr703n.
Configure the IP adress of your computer to and put the file
on the tftp server.

On the serial terminal enter the following lines :
hornet> tftpboot 0x81000000 openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin
hornet> erase 0x9f020000 +0x3c0000
hornet> cp.b 0x81000000 0x9f020000 0x3c0000
hornet> bootm 9f020000

wait until it has uploaded and another extra couple of second before reset.

unplug the power, wait a bit, replug, the system should be freshly working...


Hi fertito,
Thank you for publishing this. It seems like a really nice way to go.
Have you seen the Carambola project:

It might be a smaller/lighter/cheaper and easier to access OpenWRT Router.
Do you think a Carambola Router might work as well?
(unfortunately I have not enough Linux knowledge to make it to work)

(Have you thought about also using 3G / UMTS / LTE instead of WiFi?)
This would be the ultimate Solution?

Thanks again,

Yes, saw the carambola few days ago,
not cheaper, and not so smaller, you have to put an additional board if you want usb or ethernet...

but it should work... I like the ulf connector, on my next post I'll explain how I putted one on mine ;)

Yes, I'm working on making it work with my huawei E220 3G modem, seems to connect, but I can't access it from outside... a matter of time ;)

I am not very good too with linux, all I did is tried what I found on the web and summarize them here...
Thanks for the quick answer.
I have seen the price <20€ - so I ordered a router to try myself.

Pretty curious ;-)


About soldering the wires, if you clean the surface with a flux pen, they will be much easier to solder and the solder will stick.
Would be pretty cool if 3G USB modem together with OSPF dynamic routing protocol and GRE tunnel protocol where support on open wrt for this tiny router platform.

Then cool setups could be created. Routing loopbacks between two wrt routers, using multiple paths. One path using WIFI and one using GRE tunnel via alternative paths like Internet (via 3G, UMTS, Eth or what ever as second path). Then the IP address of the device (looback IP) for control will always be the same, regardless of physical path used (3G or WIFI).

Dynamic routing protocol tuned for fast convergence, choosing between WIFI and Internet path, where WIFI is preferred path due to high bandwidth and low latency. If WIFI interfaces goes down it would trigger an instant reroute, but if connectivity is lost, then it would take OSPF hello intervall x deadintervall.to detect. OSPF paramters would probably be needed to be tuned for fast convergence, otherwise it would take to long for convergence.

I dont know if this would work on a wrt based router; It would certainly be possible to configure on a Cisco router. As principles are the same, I guess it wouldn't be hard to implement in wrt (not many mechanisms needed). If there is any benefit of it. Just some thoughts. As its design as a router from the beginning, as well as software. Why not take advantage of that as well?

Maybe routing features doesn't fit on this small platform.
ah, hue, ok... ;)
sorry, I'm not at ease at all with network configuration, but I should give a try ;)
Just some thoughts that came through my mind. I have done similar setups with Cisco routers as I described, but in more fixed environments. Not a flying harsh radio environment, where packets might be lost in another way. My setup have been Leased lines, satellite (not always stable) and dial backup network to power plants in hard to get areas.Where there is hard to establish IP communication due to geographic locations, but dynamic path selection is needed for dynamic path selection, depending on available network for the moment.

I think same kind of setup would be possible for these routers and scenario your working on, if the features fit into this small plattform. If not, it wouldn't be possible i guess..I Haven't check that. Would be nice to use the loopback to address as one management IP of the router, the IP wouldn't change when changing the network media/path used to access the device.

The challenge might be getting the fail over mechanism fast enough without getting it flapping when loosing some packets over wifi link.

I think it would be interesting to test though, to see whats achievable. I got a couple of those routers omw to my home atm. I just couldn't resist ordering a couple. I think they are in the customs now. Customs is robbing me always..

I could do a simple network drawing (easier to configure if parameters are know and defined already) if you would like, if its interesting for you.

I'm not updated regarding how Open Wrt works and whats possible with this particular hw.

Would GRE tunnel and OSPF support be possible on this particular platform?
Hi Fertito,

Thanks for your post on unbricking a wr703n. I've managed to brick 2! I hooked up the serial port on both routers, but when I open a serial connection and power up the router, I only get scrambled output (gibberish). Both routers give me the same scrambled output. I've tried different baud rates, but no success in getting a uboot prompt. I've checked my usb to serial cable with a simple loopback test and it seems to be working fine. Any thoughts or suggestions for me? Thanks!
you have to be fast and ready ;)

before powering the wr703n, your serial adapter must be plugged and the serial interface ready and configured (115200bds 8n1) to send your keyboard input.

once this is done, power on the router and type
followed by enter.
It should enter in console mode ;)
Thanks for your quick response. I must be missing something essential. I've tried what you suggest, but I still can't get into console mode. Is it normal to get scrambled output from the wr703n when not in console mode? I'm using minicom. How do I make sure I've got XON/XOFF correctly set and how do I enter "tpl" in the terminal. Perhaps I'm doing this wrong. Thanks again for your help.
Hi fertito,

My trouble was with my serial adapter. Finally got a new one in the mail today and now all my bricked routers are now unbricked! Thanks so much for your post!



I new to the world of OpenWRT and I just bricked my brand new wr703n.

I think tried to flash it with the wrong image (sysupgrade instead of factory).


Right now I don't know how to access it.

I tried different things but none seems to work (failsafe etc).


Therefore I will try the method described above but I feel I need some more details.

I have ordered this cable :https://www.modmypi....ry-Pi-2-800x800.

and these : https://www.modmypi....e-2-800x800.jpg


Now I do not understand which cable I have to solder to which pin.

How shoud I power the router ?


Any help would be really much appreciated.


Thanks a lot.


I really don't know how is wired the cable you bought, I can't really help you on this, you need to connect the TX pin of a serial cable to the RX test point, the RX pin to the TX test point and the ground.

The wr703n can be powered using the usb cable... ;)

So the 5V, the 3,3V and the 0 point circled in red on the picture are useless here ?



Once everything soldered and ready can I do everything from a win7 computer ? Is it better to use a linux liveCD (and if so, which distro?)


Is it likely that I need a special driver ?


Again thank you so much.

yes, useless for what you need ;)


yes, there is no reason it wouldn't work on a win7 machine.

you just need to have your usb serial cable plugged with the right drivers and a serial terminal opened ready to receive your typing.


I have to wait for the cable to be shipped and will then try it right away.

Do you think I can do the trick without soldering provided that a friend makes sure the cables keep in touch with the Rx test point, Tx test point and grounf on the board side ?

you can try, but you need to hold it in place for few minutes...


If you have flux it's pretty easy to solder a wire on it.

once everything was in place, I putted hot-glue to be sure it won't move by accident...

Well I don't have a soldering iron or anything and if possible I would try to avoid buying one.

I do not have hot glue nor flux either. (By the way is flux supposed to be applied on the place you will soder or where you to not want to solder?)


I will try to make it with a friend.


So once everything is set up, I plug power into the router and I am supposed to see things on the pc ?

When should I type "tpl" in ?


I have read somewhere that it is hard to be sure what command to send, how did you find out it was tpl ?


Again thanks a lot.





(Sorry for my english, I'm french)

On peut parler en français alors si tu préfères ;)

pour la masse, tu peux l'oublier, elle viendra quand tu brancheras le routeur en usb.


il faut que ton cable usb-serial soit branché, connécté à un terminal série comme minicom, realterm, docklight, configuré en 115200bds 8n1 et près à recevoir des commandes claviers.


donc dès que tu vas brancher le routeur en usb (cela ne fait que l'alimenter), tu devrais voir rapidement arriver des lignes de communication qui viennent du routeur, c'est le moment de taper "tpl" suivit de entrée. c'est dès les premières secondes...


je sais plus trop où j'ai vu cette commande, mais elle marche ;)

je l'ai utilisé quelques fois déjà ;)


le flux permet de nettoyer les piste et aide à l'accroche de la soudure sur le cuivre.





Hi, Thanks for the great article for unbricking a wr703n. I made the changes, got an ftdi cable, can see on my serial console the device booting, ending with a panic and halting. My question: how do I make it go into the rescue mode? Tried typing tpl at many different moments, but never managed to get the hornet prompt. What am I missing? Thanks for your help. Regards, Kurantje

October 2015

12 13 1415161718

Recent Comments